ODBC: connection failled

SlimaniSlimani Super Learner
edited August 2021 in General discussion

Hello,

We are facing some issues when we try to apply ODBC procedure (https://docs.experianaperture.io/data-quality/aperture-data-studio-v2/use-odata-and-odbc/access-data-using-odbc/)

We have the message: Failed to authentificate




For your information, we tested the connection with 2 aperture accounts: administrator user, and my own user account.


Thank you in advance for your help


Best regards

Tagged:

Answers

  • Josh BoxerJosh Boxer Administrator
    edited August 2021

    Hi Ali, out of interest is there a reason you are choosing to use ODBC over the newer OData?

    You will find OData much simpler to setup, which is why I ask.


  • Josh BoxerJosh Boxer Administrator

    Your screengrab shows that you entered the "Service Data Source". Assuming that you did this by hitting the "..." (and did not type ADS_Development manually) which indicates connection to the general system else you would not have been presented with the list of sources.

    If you made incorrect login attempts using the test connection button the account would be temporarily locked (like making false attempts on the UI). You could have locked these accounts so please check this, and the credentials, by logging into the UI.

    The error indicates an authentication issue, but "Test Connection" can present generic errors, so it is worth testing in an application like Excel noted as the 3rd step in the link you sent above.

    a port change requires a server restart

    have you enabled TLS for ODBC on the server side? If so have you set up client security on the driver Security tab? 

    If you are still having issues then it would help if you can provide any further information to help us diagnose.

  • SlimaniSlimani Super Learner

    Hi Josh,


    Now it's much =bnetter , we are able to connect but unfortunately we have a message telling us Table name is empty


    NB: regarding custom properties, we are not aware about its value !



    Thank you in advance for your help

  • Josh BoxerJosh Boxer Administrator
    edited August 2021

    A Table = Data Studio Dataset (and Schema = Data Studio Space). Did you enable some Datasets (as mentioned on the page you linked) ? https://docs.experianaperture.io/data-quality/aperture-data-studio-v2/use-odata-and-odbc/access-data-using-odbc/#makedatasetsavailableviaodbc

    Custom Properties I think is for timeout values etc. so can probably stay blank.

    The other possible issue is that the 'Choose Data Source' dialogue should have the Data Source you created above 'ADS_Development_64'

Sign In or Register to comment.