Workflow is not in an executable state but no errors exist

Sarah Member
edited December 4 in General

Hi DQ Community,

I have a workflow that I can't run or publish because I get error messages telling me that one or more workflow steps are invalid, or that the workflow is not in an executable state. I've been through the workflow multiple times and all the steps are valid - I can open the final step and view results, and none of the steps have red error flags on. I can't see any floating un-connected steps anywhere. Has anyone else ever come across this and if so how did you resolve it? I've tried copying the workflow but the same errors come up in the copied version.

Thanks in advance!

Best Answer

  • Ian Hayden
    Ian Hayden Administrator
    Answer ✓

    Hi Sarah,

    Josh forwarded me your workflow and I've taken a look at it.

    The problem is that the StudentInitiative_1 source was changed and one of it's fields was renamed (by the looks of it INITIATIVEID changed to STUINITID). This field is used in its downstream transform step and the "Filter For Coverage" step which invalidates these steps and the workflow. This check is happening at publish/run time, but not when you open the workflow. When you open the workflow or change a source Data Studio should detect that the source has changed and prompt you to remap the columns. I will raise a bug to look into why this has not happened in this case.

    The easiest workaround is to switch the source to StudentInitiative (which shares the same schema), which will detect the change and prompt to remap the columns, then change it back to StudentInitiative_1 (which does not need remapping again). The workflow should become valid again.

    Best Regards,



  • Josh Boxer
    Josh Boxer Administrator

    Hi Sarah

    I think your comment "floating or unconnected steps anywhere" is likely the answer. If you click 'Report' to generate a Workflow report and see the message "Workflow <name> is incomplete." then I definitely think this is the issue.

    If you zoom all the way out using the zoom action buttons then you might see a rogue step on the canvas or the mini-map in the bottom right corner.

    Clicking 'Arrange' will prevent any steps sitting on top of each other and move any unattached steps to the left side of the Workflow (or if you really do not want to re-arrange steps you could clone the workflow and Arrange in the new version)

    If this does not answer the questions can you export the Workflow with any associated objects and share it so we can have a look

  • Josh Boxer
    Josh Boxer Administrator

    Another thought, your workflow is not using any re-usable /embedded workflows?

  • Thanks Josh! No it's not using any re-usable workflows. I've tried using Arrange this morning and I still can't see any unattached steps anywhere; I also tried zooming out and can't see any in the mini-map. What would be the best way to share it with you once I've exported it?

    Thanks again for your help.

  • Thank you so much Ian, that has worked! Thanks for raising this as a bug too.

  • Ian Hayden
    Ian Hayden Administrator

    You're most welcome!