Has anyone else had issues connecting to an AWS RDS server? And if so how did you manage to connect?

We are having issues connecting to an RDS server, the port is definitely open and the username/password is correct. We have tried putting encryption parameters in but still won't work. Our non-RDS servers are working perfectly, it is just rds with the issues.

Best Answers

  • Henry SimmsHenry Simms Administrator
    Answer ✓

    Hi @KMaggs , what RDS database engine are you using? And what connection parameters are you trying?

    I haven't tried RDS connections specifically but I believe it should work, so it's probably a case of finding the right combination of connection params to use.

  • Henry SimmsHenry Simms Administrator
    edited February 22 Answer ✓

    Hi @KMaggs

    The problem you may be having is that Data Studio doesn't by default trust the certificate authority used by your RDS DB instance. If that's the case you'd see a PKIX error like this when testing the connection:

    The most straightforward solution to this, which worked for me, was to tell the JDBC driver to not validate the certificate that is sent by the database server, using ValidateServerCertificate=false

    Alternatively, if you do want Data Studio to validate the cert, you'll have to allow it to trust the CA. You should download the relevant certificate from AWS for your RDS's region and add it to Data Studio's truststore, using the packaged Java keytool:

    "C:\Program Files\Experian\Aperture Data Studio 2.9.9\java64\bin\keytool.exe" -import -trustcacerts -alias AWSUSEast2 -file "C:\mydownloads\us-east-2-bundle.pem" -keystore "C:\ApertureDataStudio\certificates\cacerts"

    Where the paths will need to be changed based on your deployment.

    Both approaches allowed me to load data from my AWS RDS SQL Server DB.


  • We have tried CryptoProtocolVersion = TLSv1.2 and EncryptionMethod = ssl

    Database engine is Microsoft SQL Server

  • That worked perfectly! Thank you!!

Sign In or Register to comment.