Copy of FiServ Files uploaded into DA & use of the Metro2 Parser

Does anyone use Data Arc with a copy of a FiServ Metro2 File? We are setting this up as net new and it appears that FiServ does not include the RDW in the header or the file. This is limiting our ability to upload the dataset into the tool.

Has anyone had any experience with this?


  • Josh BoxerJosh Boxer Administrator

    Hi Cherish

    I believe there is a way to handle these files although it has not come up in quite a long time

    1. get your administrator to open the Server.Properties file (by default here: C:\Program Files\Experian\Aperture Data Studio 2.11.7)
    2. Add 'Metro2.addunrecordedbdw = false'
    3. Save and restart the Data Studio Server

    Hopefully this works successfully. If you or FiServ have a test/sample file then please send it to us so that we can test this for you


  • Josh,

    Will this impact other files that we have that do have and use and RDW? Our personal loan Metro2 file has that and we have J1/j2 rules that leverage that field. Also, what if the file is variable length? One of our team members did figure out how to use the Metadata to pull in a test file to our environment and we did run it through our rules but the Metadata does not account for variable length file format.

  • Vaughan PhillipsVaughan Phillips Experian Employee

    Hi Cherish,

    You can handle this in one of two ways:
    1. Create a copy of the workflow that Maps the inbound Metro2 file 0 map to target. With this approach, only map the fields that you have in the FiServ M2 file and if you have rules in place that use the RDW field then you should also create a copy of the 1. DataArc 360 Rules workflow and disable those rules.
    2. Create a new Space to handle FiServ Metro2 files. With this approach you can have full separation of the FiServ processing from your existing processing.

    Hope this helps, let us know if you have any follow up questions.


  • Vaugh,

    This helps once we get the file into DA - correct. The issue we were having was loading the file into DA all together. The Metro2 parser that we normally selected would not work. But I will update the 0 map to target. thanks

  • Vaughan PhillipsVaughan Phillips Experian Employee

    Hi Cherish,

    Sounds like the FiServ file has a different record layout to the the Metro2 format and it's not playing well with the Metro2 parser to

    Would it be possible for you to share a FiServ file with us?


  • Josh BoxerJosh Boxer Administrator
    edited July 14

    Thanks for sharing the file. If you were unable to load the file at all (since it does not have a file extension) then upgrading to Data Studio version 2.11+ will fix that issue and allow you select any parser. This helps as you can load as a single column then amend the file into a standard Metro2 format, so that is matches your other files, by adding the 4 digit RDW to each line and to the header (you could also do this in Excel if the volumes are fairly small):

    There are some other options with other parsers like Grok, but I think this gets more complex than pre-processing and re-loading the file once it is in the correct format

    Downloading the amended data as a CSV then loading and selecting Metro2 parser looks to be successful:

Sign In or Register to comment.